[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Ksync: RE: Problem of Unalbe to create MiDlet



>>


>>-----Original Message-----
>>From: Aichin [mailto:aichin@comax.com.tw] 
>>Sent: Tuesday, March 19, 2002 11:36 AM
>>To: Oleg A Oksyuk
>>Subject: Re: Problem of Unalbe to create MiDlet
>>
>>
>>Oleg A Oksyuk wrote:
>>
>>>Hi, Aichin,
>>>
>>>To start kSync_client under Wireless Toolkit1.0.3 beta, you need to 
>>>unpack jar file, because 1.0.3 beta couldn't get classes 
>>from jar. So 
>>>you need 1.create ksync_client forlder in app folder of Toolkit
>>>2.create bin folder in ksync_client folder
>>>3.copy jar and jad to bin folder
>>>4.create classes folder in ksync_client folder
>>>5.unpack jar to classes folder
>>>
>>>Regards,
>>>Oleg
>>>
>>>
>>>
>>>
>>>
>>>
>>>>>-----Original Message-----
>>>>>From: Aichin [mailto:aichin@comax.com.tw]
>>>>>Sent: Monday, March 18, 2002 7:36 AM
>>>>>To: oleg.oksyuk@enhydra.org
>>>>>Subject: Problem of Unalbe to create MiDlet
>>>>>
>>>>>
>>>>>Dear sir,
>>>>>   I am currently testing the Ksync project.  I can not find the
>>>>>Wireless Toolkit1.0.2 from SUN website. So, I download 
>>version 1.0.3.
>>>>>
>>>>>I install enhydra3.1 in my Linux Mandrake 8.1 server, then I
>>>>>fllow the 
>>>>>instruction to build ksync server and client under that. 
>>At Beginning 
>>>>>everthing looks good until I run the ksync_client using 
>>>>>toolkit. I got 
>>>>>the error message as below:
>>>>>
>>>>>"Unable to create MIDlet
>>>>>com.reaxion.tequila.client.syncml.ui.SyncMidlet"
>>>>>
>>>>>Did I do somthing wrong?
>>>>>
>>>>>Best Regards,
>>>>>Aichin Wu
>>>>>
>>>>>
>>>>>
>>>
>>>
>>Hi, Oleg,
>>    Thank you very much for your instruction. However, the really 
>>problem I found is in jar file which does not inculde all classes. 
>>During the building process, it actually come out a error message in 
>>"result.txt" file as below:
>>
>>"Error preverifying class org.kxml.Attribute
>>    java/lang/NoClassDefFoundError: java/lang/Object"

Try to change j2me_dir value in build.xml to valid path to J2ME.
<property name="j2me_dir" value="c:\j2mewtk"/>

>>
>>I didn't know how to fix this problem exactly, but I used compiled 
>>classes to make a new jar files. Then I got it work finally. 
>>Now, I still have one question. During the test I always got 
>>a "Ubnormal 
>>session finish" at the end. What is that mean?

I'll be able to help you if you send me all client and server logs

>> 
>>Regards,
>>Aichin
>>
>>
>>
>>
>>
>>